Announcement

Collapse

ZEALOTRY Users: Critical Notice on Continued Use

Edit: Our new HTML5 client (Orchil) is now open for beta testing in The Eternal City and Grendel's Revenge. Feel free to try give it a whirl at http://test.skotos.net/orchil/

Edit: We have made great strides toward a new HTML5 client, which should offer a replacement to Zealotry. We're hoping to release that in the very near future, but in the meantime, using Pale Moon remains the best method for ensuring there is zero interruption to your game playing during the transition.

As of November 14, Mozilla will be auto-updating all copies of Mozilla Firefox to Mozilla 57, a new edition of their browser that will disable all legacy add-ons. This will probably include the majority of the plug-ins that you use on Mozilla, including the Skotos Zealotry plug-in.

This is a big problem for us because Zealotry is the most stable of our clients at this time, and the one that we believe is in the widest use. There's unfortunately no easy way to update it, because we'd have to rewrite it from practically scratch, using their new programming system.

There are tricks that you could use to to prevent Mozilla updates, but we don't particularly suggest them, as you want to have a clean, secure browser. Fortunately, there are two alternative browsers that will support Zealotry. Each of them branched off of an earlier version of Mozilla Firefox, and each of them continues to be updated for important security issues.

Pale Moon Browser

The Pale Moon browser is our suggested replacement. It is a totally separate browser that branched off of Firefox some years ago. It will continue to support the classic plug-ins.

To install it:
  • Install Pale Moon (Windows & UNIX only)
  • Install the Zealotry XPI on Pale Moon
  • Restart the Pale Moon Browser
  • Play on Pale Moon

The official version of Pale Moon only supports Windows and UNIX, but you can also get a slightly less official version of Pale Moon for the Mac. We've tested it out and it looks like it's clean and works correctly, but use your own level of caution in working with the Mac variant.

If You Have Errors

Some users are experiencing "Content Encoding Errors" when using Pale Moon and Zealotry. As best we can tell, this is due to an incompatibility between Windows 8.1, Pale Moon, and Plugins. If you have this problem (or any other), we suggest instead using Mozilla's extended-release version of Firefox, which branched at Firefox 52. It's expected to remain supported until at least June 28, 2018, by which time Mozilla is planning to jump their ESR to a post-plugin phase. This is therefore a short-term solution, but we expect to have full release of our New HTML5 client well before that.

To install it:
The Big Picture

Our larger-scale goal is to introduce a new client that will be usable on any browser and make our games generally more accessible. We've had a HTML5 client in process since last year, but are currently hitting roadblocks that make a deployment before November 14 problematic. We've also just started a second project, which would be more specifically focused as a Zealotry replacement, without worries about new bells or new whistles. Both of these possibilities are being done out-of-house, by Skotos players, but they're receiving our highest level of attention for whatever support they need, as this is all our top priority.

So, consider this a short-term fix, but in the meantime if you use Zealotry, please download one of the alternative browsers and test them out ASAP.
See more
See less

TWiki Editing Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TWiki Editing Issues

    Hello all,

    I'm wondering if anyone is presently having twiki editing issues. Specifically, when you go to preview new edits to a page, it says the page is already being edited by nobody, and clicking "edit anyway" then clicking "preview" a second time loops you back to "already being edited" again.

    If so, please let me know the browser you were using and which twiki web you were trying to edit (ie: public, battlers, etc).
    StoryHost Kurzon
    Castle Marrach Staff

    kurzon.marrach@outlook.com

    The destiny of the world is determined less by the battles that are lost and won than by the stories it loves and believes in.

  • #2
    Yes, trouble started for me last night when editing the Battle Guild twiki. I use Firefox.
    However, I'm receiving a different Topic Save Error, one that lets me save it anyway by clicking 'OK'. Here it is:

    ----------------------------------------------------------------------------------------------------------
    During save of file Battlers.BgTreasuryRecords an error was found by the version control system. Please notify your TWiki administrator.

    /usr/bin/ci -q -l -m'none' -t-none -w'Trisan' /var/www/wikis/marrach/data/Battlers/BgTreasuryRecords.txt 2>&1 1>/dev/null
    ci: /var/www/wikis/marrach/data/Battlers/BgTreasuryRecords.txt,v: No space left on device


    Go back in your browser and save your changes locally.
    Last edited by Trisan; 07-13-2017, 12:39 PM.
    Trisan Allanon
    ~ We journey to be great.
    Should we never achieve greatness,
    At least we have a great tale.
    Thus, mayhaps we achieved greatness after all. ~

    Comment


    • #3
      Mine does this still, I get this message for the Royal Library Inventory in Art & Crafting. I'm using pale moon at the moment but it does the same on Chrome. Anytime I click edit anyway it takes me right back to this message.

      ---------------------------------------------------------------------------------------------------------------

      Topic is locked by an other user


      There is a possibility that Nobody is editing this topic. Please ask the contributor before making changes to this topic.
      • To look at the text without editing the topic click on the View raw text link.
      • To edit anyway click on the Edit anyway link.
      • To cancel go back in your browser or click on Cancel.
      Note: Locking gets reset after 60 minutes of inactivity, the earliest in minutes.

      ~*~*~*~*~*~*~
      Apprentice Jeweler
      Royal Purse Bearer
      Royal Librarian
      Honored Guest
      Assistant Dean of the Royal Collegium

      Comment


      • #4
        Yes. I'm having issues with the Twiki and the forums. The forums say my post is made, but it never shows up. Twiki gives me the same error Adeline is getting, and also gives another random error if I try to edit tables and stuff without clicking the main edit button. For example:
        Topic save error

        During save of file Hairstylists.July2017 an error was found by the version control system. Please notify your TWiki administrator.

        /usr/bin/ci -q -l -m'none' -t-none -w'JosieB' /var/www/wikis/marrach/data/Hairstylists/July2017.txt 2>&1 1>/dev/null
        ci: /var/www/wikis/marrach/data/Hairstylists/July2017.txt,v: No space left on device


        Go back in your browser and save your changes locally.
        ------------------------------------------------------------------------------------------------------------------------------

        This happened for me in the Muses, Hairstylists, Duelists, and the Treasury pages. I use Firefox for my web browser.

        ** Edit: I see now that this forum post shows up, but the posts I made earlier about painting bells and Duelist practice never went through. I'll go check and try to post them again.

        ** Double Edit: Tried to post under my Duelist practice and got this error:

        Edit Conversation
        There has been a database error, and the current page cannot be displayed. Site staff have been notified.
        Last edited by Josie_Brennan; 07-13-2017, 01:10 PM. Reason: Adding stuff and things
        You need power only when you want to do something harmful, otherwise love is enough to get everything done. ~~Charlie Chaplin~~
        No matter how long the winter, spring is sure to follow. ~~Proverb~~

        Comment


        • #5
          Cannot edit any pages I have access too. Nobody is editing it. Using Chrome.

          Comment


          • #6
            Yep, having tons of trouble... Just as Howe is saying .. Nobody is editing. Using Chrome

            Loyal Honored Guest to Her Majesty's Winter Court
            Servant to Lord Sicard, Her Majesty's Royal Champion
            LPA Director/Treasurer
            Elder Battler Teacher/Treasurer
            Masque in the Unity
            Lead Apprentice Embinder

            “No thief, however skillful, can rob one of knowledge, and that is why knowledge is the best and safest treasure to acquire.” ―L. Frank Baum

            Comment


            • #7
              When Editing and Saving a Topic, I receive the following message:

              Topic save error

              During save of file Jewelers.JewelersMembers an error was found by the version control system. Please notify your TWiki administrator.

              /usr/bin/ci -q -l -m'none' -t-none -w'Lilly' /var/www/wikis/marrach/data/Jewelers/JewelersMembers.txt 2>&1 1>/dev/null
              ci: /var/www/wikis/marrach/data/Jewelers/JewelersMembers.txt,v: No space left on device


              Go back in your browser and save your changes locally.
              Lillian-Rose Annabella Grace (aka "Lilly")
              * Courtier
              * Royal Jeweler
              * Chief Scribe of the Chambers

              Comment


              • #8
                Very likely due to the "inode" problem that was causing various issues with the server.

                Comment

                Working...
                X