Announcement

Collapse
No announcement yet.

can't get in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • can't get in

    Originally posted by Zell
    Dear Dwellers,

    After a minor rewrite and incorporation of some fixes from Kalle and Kargh, Zealous should now work on recent Mozillas and on flakier connections.

    Since I am not certain it will work on all older browsers, I have not replaced the old distribution, but made an interim one, labelled 'NewZ' on the Marrach portal.

    If you can, please try it out and let me know how it works for you.

    Zell
    I can't seem to load the new Zealous. I've cleared my cache in case the old Zealous was conflicting, but it still seems not to be able to load. I wait and the activity LED's on my modem cease to flicker after a while and the client never seems to load.
    It is in vain to say that enlightened statesmen will be able to adjust these clashing interests and render them all subservient to the public good. Enlightened statesmen will not always be at the helm....

    James Madison, "Federalist No. 10"

  • #2
    I'm having the same issue. It will load up until you see "Connecting..." and then nothing more.
    "If you don't like something, change it.
    If you can't change it, change your attitude.
    Don't complain."
    -Maya Angelou

    "Listen to Age. Age smart." - LSP Geist

    Comment


    • #3
      Er. I posted that in the wrong thread. Meant to make a new topic. Oh well.
      It is in vain to say that enlightened statesmen will be able to adjust these clashing interests and render them all subservient to the public good. Enlightened statesmen will not always be at the helm....

      James Madison, "Federalist No. 10"

      Comment


      • #4
        Originally posted by Age
        I'm having the same issue. It will load up until you see "Connecting..." and then nothing more.
        When this happened, were you able to connect to the game using the other clients? Is it by any chance working now?

        In other words: I want to make sure it's the client that is at fault, rather than a hiccup in general loginability.

        Zell

        Comment


        • #5
          I'm able to use the old zealous just fine, as well as alice (I have both running right now as we speak), but as for the newZ, I get as far as Connecting... and it just sits there.
          "If you don't like something, change it.
          If you can't change it, change your attitude.
          Don't complain."
          -Maya Angelou

          "Listen to Age. Age smart." - LSP Geist

          Comment


          • #6
            Originally posted by Age
            I'm able to use the old zealous just fine, as well as alice (I have both running right now as we speak), but as for the newZ, I get as far as Connecting... and it just sits there.
            OK! Thanks. Then my next request is, could you tell me which browser you are using, including version number? Also, if possible, if you could bring up the Javascript Console, hit the little 'Clear' button, then try to connect by clicking on NewZ, and let me know if any errors appear and if so, what they are.

            On my version of Mozilla, the JavaScript Console can be summoned through the Tools menu, in the Web Development sub-menu.

            I'd dearly appreciate your help in this.

            Zell

            Comment


            • #7
              Mozilla 1.2.1

              Cleared the Javascript console, and I'm still having the same issue. "Connecting ..." is as far as I get. No maps or text.
              "If you don't like something, change it.
              If you can't change it, change your attitude.
              Don't complain."
              -Maya Angelou

              "Listen to Age. Age smart." - LSP Geist

              Comment


              • #8
                Same problem here.

                Mozilla 1.2.1

                Old Zealous connected right up.

                No console messages on regular Java console.

                JavaScript console reads -
                Error: [Exception... "'Permission denied to call method UnnamedClass.write' when calling method: [nsIStreamProvider:: onDataWritable]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

                Enjoy.

                StoryCoder Geist

                Comment


                • #9
                  The new version is "suited" more for the new Mozilla's out there.

                  In fact, it is using parts of the code from the newer brands of Mozilla (1.3-1.4). If you upgrade Mozilla, NewZ might work better.

                  Mozilla can be found here:
                  http://www.mozilla.org/

                  Mozilla 1.3 direct download link

                  -Kalle.
                  "I contend that we are both atheists. I just believe in one fewer god than you do. When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours."
                  -- Stephen Roberts

                  Comment


                  • #10
                    As a note:

                    I updated mozilla to 1.3.1, and while the newZ took longer to load then the old one, it DID load.

                    So the problem lies in versions prior to 1.3.1... Thanks Kalle.
                    "If you don't like something, change it.
                    If you can't change it, change your attitude.
                    Don't complain."
                    -Maya Angelou

                    "Listen to Age. Age smart." - LSP Geist

                    Comment


                    • #11
                      The extra time is probably due to some system maintenance taking place currently.

                      I believe the load time is actually faster on the new zealous normally.

                      -Kalle.
                      "I contend that we are both atheists. I just believe in one fewer god than you do. When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours."
                      -- Stephen Roberts

                      Comment


                      • #12
                        Originally posted by sc_kalle
                        The new version is "suited" more for the new Mozilla's out there.
                        While this is true, I remain hopeful that we can produce a Zealous version that actually runs on older -and- newer Mozillas.

                        Zell

                        Comment


                        • #13
                          Mm.. I've not looked at the new code yet but I would imagine some sort of version check could be in place.. I suppose the trouble is... finding all the spots that could be creating an issue.

                          While it would be nice to support all version, 1.3 branch and above are defiantely superior to 1.2 branch.
                          Jess

                          "You've just been perverted and befouled by the dark side, otherwise known as open-source. Typical, though, for your heart is already stained black with the corruption of your unholy programming." -- StoryCoder Aquilus

                          "Any fool can criticize, condemn, and complain -- and most fools do."
                          Dale Carnegie

                          "You should never underestimate the predictability of stupidity."
                          Snatch

                          Kalle says, "Can I see your thing that you give it with?"
                          Kalle rolls 1D6 to speak English: DC 2. Rolls a 1. *FUMBLE*

                          "The only sensible way to estimate the stability of a Windows server is to power it down and try it out as a step ladder."

                          Comment


                          • #14
                            Which means Netscape is bloody slow because they're still using 1.21, I believe. I had to download the actual Mozilla browser.
                            It is in vain to say that enlightened statesmen will be able to adjust these clashing interests and render them all subservient to the public good. Enlightened statesmen will not always be at the helm....

                            James Madison, "Federalist No. 10"

                            Comment


                            • #15
                              Originally posted by Zell
                              I remain hopeful that we can produce a Zealous version that actually runs on older -and- newer Mozillas.
                              This turned out to be quite doable, and even -- after quite a bit of investigation -- quite easy.

                              I think the 'NewZ' link now runs on all versions of Mozilla from 1.0 and up, and I would dearly love if anybody who's still running an old version could go test it.

                              If I don't get more reports that it's buggy I intend to replace Z with NewZ very soon.

                              Zell

                              Comment

                              Working...
                              X