Announcement

Collapse

Grendel's Revenge Free Accounts

On December 15th of 2012, Grendel's Revenge enabled free accounts for play. This announcement is following in the suit of TEC's own free account announcement, serving as a reminder to any new or returning players that are browsing the forums.

For all the details about what free accounts are, look no further than here: http://forum.skotos.net/showthread.php?t=95655

In order to log into GR for free, simply visit this page to sign into your Skotos account (ignoring any subscription notices it may give): https://www.skotos.net/user/login.php

Then click the following link for Zealotry/Firefox: zealotry:@GrendelsRevenge.skotos.net...login/Zealotry

Or this link for Alice/Internet Explorer: http://grendelsrevenge.skotos.net/mo...in/alice.shtml

Problems? Questions? You can email the GR staff group at grendel.staff@gmail.com
See more
See less

Client for GR

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Client for GR

    When I click play now, and then the bigger play now, it goes to a blank black screen and a new screen with the client doesn't pop up. I was wondering what could I do to make it work again?
    Apartius' Player - David Do

  • #2
    hmm maybe you need to download the client again.
    Click Magus for luck

    Comment


    • #3
      Do you have a popup blocker on? If so, turn it off.
      <Zetsu the Vampire grumbles: [ GR's like meth... you try it once and for the next 10 years you're still hooked to it no matter how bad it gets ]>

      Comment


      • #4
        also, check to make sure if you have a firewall that its not blocking the alice client.

        They're laughing at you behind your back.
        They all want to see you die a horrible death.
        They want you to put your pants back on.
        You squint.

        Comment


        • #5
          I'm getting the same thing as Boypet was now.

          I click on Play Now on the left hand side and it goes to the play now screen then I click play now, and it would normally go to the login page but it doesn't, just goes to a black page like the client opener page. So I go to the login page via favourites and log in as per usual. I go to play now again but it still goes to the same black page, and nothing else happens. I have no popup blocker, I have no firewall. The window for the client wont even come up at all so, yeah.... help.... please...
          Rythgen says:
          "arg! i would defend myself but my massive schlong prevents me from moving!"
          The current rune bearer is Jinn the Hydra, who is located very far away to the northeast at a hot shaft.

          Comment


          • #6
            I only have a few minutes here to post, but...

            Check your ActiveX settings in Tools>Internet Options>Security, and Custom Level. I suggest putting everything at Prompt initially, except the stuff that says "n0t marked as safe" and "unsigned", which should be set to Disable.

            Make sure you got all your Java.

            I slapped together a simple page to help reinstall your client. Go to this link to find it: http://comp.uark.edu/~jas29/grendel/trouble/

            There's a few more things, but I gotta run.
            Blackhand

            Comment


            • #7
              Whew, I fixed it, thanks Asmod!
              I did a windows update and now everything's working peachy again.
              Yay!
              Rythgen says:
              "arg! i would defend myself but my massive schlong prevents me from moving!"
              The current rune bearer is Jinn the Hydra, who is located very far away to the northeast at a hot shaft.

              Comment


              • #8
                *flexles*

                Few things can withstand the fury of a windows update!

                They're laughing at you behind your back.
                They all want to see you die a horrible death.
                They want you to put your pants back on.
                You squint.

                Comment


                • #9
                  Apparently so....I mean, you're still around, aren't you?

                  Comment

                  Working...
                  X